2
$\begingroup$

I am Trying to use Funcube Dongle Pro+ on Windows with Gnu radio companion with no success.

My PC is detecting The Funcube Dongle Pro+, and it works on SDR#, But It doesn't work on Gnu Radio. I have tried Installing Ubuntu with Gnu Radio on a virtual machine and when I try to run The Flow graph Nothing shoes up in the sink and the frequency control software (Qthid) crashes.

How do I get Funcube Dongle to work with Gnu Radio, I prefer windows but If I can get it to work on Linux it will be great too.

$\endgroup$
  • $\begingroup$ If you have the room on your hard drive, you could install Ubuntu in a dual-boot configuration. Making USB devices work inside a virtual machine can be difficult. $\endgroup$ – rclocher3 Nov 26 '16 at 21:27
  • $\begingroup$ The virtual machine (Ubuntu) was detecting the dongle, And the control software was detecting the dongle as well. It just crashed when I tried using Gnu Radio companion with the Funcube dongle block. $\endgroup$ – user6893910 Nov 26 '16 at 21:33
  • $\begingroup$ We'll need more background on how exactly it crashes - we can guide you through making a so-called backtrace, which shows the situation a program was in when it crashed, if you need help with that. Problem: I'm mostly offline the next two days. Is the GNU Radio mailing list an alternative for you to get help if no one else jumps in here? $\endgroup$ – Marcus Müller Nov 26 '16 at 23:13
  • $\begingroup$ The control software window just goes gray, and if I try to click on it, It sais that its stuck or frozen or something like that. Maby im not installing it the right way? Im new to Gnu radio, linux and software-defined-radios. About The GNU Radio mailing list, I haven't used it before, I can give it a try, although I can wait a couple of days. If you want I can take some screenshots of what I am doing. $\endgroup$ – user6893910 Nov 26 '16 at 23:29
2
$\begingroup$

I also have had quite some problems with linux and the FCD. It appears that is is related to bandwidth reservation of the USB bus. The FCD is a USB 1.1 device which is 12Mbit/s. As you are probably running it in a USB 2.0 port so there is a USB 2.0 to USB 1.1 arbitration unit in the USB interface chip.

The linux kernel has to allocate the bandwidth to each device USB 1.1 device on the USB 1.1 arbitration hardware and as the FCD runs at 96ksampes/second consumes a significant amount of USB 1.1 bandwidth. For memory linux requires a contiguous allocation of the USB 1.1 bandwidth for the USB device and if you a have keyboards and mice (which generally are usb 1.1) then this fragments the USB bandwidth allocation table.

If this is the case you can try two things:

1) remove everything else from the USB bus especially keyboards and mice.

2) switch to a USB 3.0 port which seems to be better specified but INTEL and the software to drive it is better/more-consistently written. It handles USB 1.1 arbitration better.

I opted for #2 and FCD seems to be working fine on linux for me.

Windows seems to do a better job of USB 1.1 arbitration/USB bandwidth allocation so yes my FCD worked in windows but not in linux.

I did look into the USB software on linux with a view to fixing it but ran away crying when faced with the complexity and the possibility that each USB chipset vendor can "do it differently" USB 2.0 is a box of hammers!!

I recall than is was also heavily dependent on the USB silicon vendor on our PC and which USB hubs/devices you have connected so what works for some, didn't for other etc etc.

It is a shame as I really like the FCD, but the fact that it is USB 1.1 is a real bummer for plugging and playing on linux.. I found.

As always your mileage may vary and with this particular problem you are almost guaranteed it will.

Here is a bug report for GQRX that details it, although the issue is not with gqrx but linux kernels treatment of USB devices.

$\endgroup$
  • $\begingroup$ Thank you for your help! I already got the dongle to work with GnuRadio linux. I got the answer from GnuRadio Mailing list archive. My problem was that the controll software for the dongle (qthid) crashed when I tried to use the dongle with GnuRadio. Apparently there was a pacage for the controll software on the universe repository. I installed it and that fixed my problem, it still crashes sometimes on some computers, but it workes for me. $\endgroup$ – user6893910 Dec 5 '16 at 9:01
  • $\begingroup$ Hi David, and welcome to ham.SE! We recommend that new users take the tour to get the most out of the site, and since you volunteered an answer, it couldn't hurt to read how to answer also. We'll look forward to more contributions from you. $\endgroup$ – rclocher3 Dec 6 '16 at 19:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.