3
$\begingroup$

I have a GNU Radio Companion flow graph, where I have the following connections:

  • 440Hz cosine wave
  • throttle block
  • audio sink

Flow Graph Screenshot

All of the above blocks use the same sample rate (48KHz).

When I execute this flow graph, I don't get a continuous note, the way I expected. Instead, it pulses on and off, several times per second. Why is this?

How can I make it output a continuous 440Hz tone?

Removing the Throttle block makes it stop cutting in and out, but it sounds even worse when I do this.

I have tried this setup, with and without the Throttle block, at all common sample rates for sound cards.

$\endgroup$
2
$\begingroup$

I ended up figuring it out. I had to do three things:

  • remove the Throttle block
  • enable the "OK to Block" option in the audio sink
  • ensure the amplitude of the sine wave is less than 1
$\endgroup$
  • $\begingroup$ indeed; GNU Radio Companion will even tell you about not using hardware blocks with a Throttle block in the same flow graph $\endgroup$ – Marcus Müller Jun 16 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.