2
$\begingroup$

So I am working on a low cost ham radio beacon using my Baofeng UV-5R radio because it is easy to use and portable. I built a simple PTT interface for a Raspberry Pi and wrote some python to transmit the information I want. However, there is one problem. I want the option to have to radio plugged in to its charger to be able to transmit for long periods of time without dying but when I plug the radio into the wall and use Raspberry Pi to transmit audio it produces a very loud hum over the radio signal and it is completely unusable. This does not happen when I plug a battery operated audio source (such as a phone) into the radio, only when I use a wall powered source such as the Pi or a computer. it also does no occur when the radio is using battery power and the Pi is plugged into the wall. It does happen when using a simple male to male aux cable and VOX PTT. I can't seem to find the problem however I suspect it to be an issue with common grounds or something of the like but I have no idea how to solve it if that is the case. Please help!

Thanks,

Mr. Schmuck

$\endgroup$
  • $\begingroup$ Fun fact: That hum will cause the noise floor on 80 meters to jump about 10 db. I have to unplug my Baofeng chargers while operating HF. When I suggest to others on our 80 meter net that they do the same, they all reported similar results. $\endgroup$ – Joshua Jan 9 '18 at 21:44
  • $\begingroup$ @Joshua did you find a solution? $\endgroup$ – MrSchmuck Jan 9 '18 at 22:31
  • $\begingroup$ MrSchmuck, the solution I found was to unplug them while operating. That fell within the KISS principle so I stopped there. $\endgroup$ – Joshua Jan 9 '18 at 23:10
  • $\begingroup$ @Joshua you know what? That's a good idea. Connect the charger when transmitting and disconnect when not using. Ill use relays for that. Thanks! $\endgroup$ – MrSchmuck Jan 9 '18 at 23:35
3
$\begingroup$

Probably the charger you're using. I ran into a similar issue with a QRP receiver I was running off a wall wart. Try with a different wall wart, or maybe a few windings through a toroid.

$\endgroup$
  • $\begingroup$ I'll give it a try $\endgroup$ – MrSchmuck Dec 29 '17 at 13:22
2
$\begingroup$

The symptoms you related sound like a classic ground loop problem. One solution is to galvanically isolate the PI circuit from the radio. This technique allows the signals to pass but not stray currents. Here is a simple circuit containing only three parts that can be built for under $10 with new parts.

schematic

simulate this circuit – Schematic created using CircuitLab

The audio transformer isolates the audio signal while the optoisolator isolates the push to talk (PTT) signal. There should be no other direct connections between the PI and the radio (or its power supply).

$\endgroup$
  • $\begingroup$ I have a relay operating the PTT. Is that okay for isolation? Also, where to get the audio transformer? $\endgroup$ – MrSchmuck Dec 29 '17 at 15:09
  • $\begingroup$ @mrschmuck The relay is a good solution for the PTT. The 600:600 ohm audio transformer can be sourced through Mouser, Digikey, Ebay, etc. $\endgroup$ – Glenn W9IQ Dec 29 '17 at 15:11
  • $\begingroup$ You can also get that transformer from an old 56k modem. $\endgroup$ – Mike Waters Dec 29 '17 at 17:26
  • $\begingroup$ So I installed an isolation transformer and no cigar. Still experienced the hum. Not sure how to fix it. I tried many different transformers it came with and just the same... $\endgroup$ – MrSchmuck Jan 1 '18 at 4:19
  • $\begingroup$ You have no other common grounds or connections between the PI or its power supply to the Baofeng, or its power supply? Have you listened to the output of the PI through an audio amplifier to see if the PI is generating the hum on the audio line? $\endgroup$ – Glenn W9IQ Jan 1 '18 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.