I installed the latest MD-380 software (from Radioddity) , but I cannot get the MD-380 software to work on Windows 10.

When I plug the MD-380 USB programming cable in my Surface Book (obviously running Windows 10), Device Manager sees "STM device in DFU Mode". (Which seems to be what I want, according other documentation I've seen online.

But when I start the start the MD-380 software, I can't get the software to read the unique device number of my radio. (Here is a pic of where it hangs. On all the howto videos online, this seems to happen automagically.)

I've uninstalled the drivers, re-installed them, and nothing. I still keep getting the same result.

Any suggestions on what I might be missing here?

  • $\begingroup$ To be completely honest: I'd try with VirtualBox + a Windows 7 VM + forwarding that USB device to the VM. Sounds faster than trying to figure out what (probably wisely enabled) security features of Windows 10 you'd have to circumvent to make some more or less shady driver work. Plus, if that driver actually has a security problem, you'd only have spoiled a throwaway virtual machine. $\endgroup$ – Marcus Müller Jan 3 '17 at 12:26
  • $\begingroup$ Please don't add “signatures” to your posts. If you just want to share your callsign, you can add it to your profile or display name. $\endgroup$ – Kevin Reid AG6YO Jan 4 '17 at 1:01
  • $\begingroup$ I have the exact same issue, and have concluded that it is something related to the HW on a Surface Book 3. I have tried installing multiple versions of CPS for MD-380, MD-2015 and MD-9600 TYT radios on a Suface Book 3 and none will talk to the radio. I have tried all sorts of driver change, emulation changes, external USB hubs, etc. to no avail. Installing on an older HP and an older Dell laptop with the same USB drivers works perfect every time. My attempts to get Tytera to even respond to my requests for help in solving this have gone unanswered. I have not heard of a single case where some $\endgroup$ – Bill Ducat Nov 22 '17 at 18:36

I had the exact same issue on the MD390 and it took some very frustrating attempts to make it work. Turns out its just that the software is just doesn't have an intuitive UI. Hopefully this will help you with your MD380, which I understand to be the same radio but without the waterproofing.

  1. Make sure you have the correct options set in the very first window that pops up (the one in your pic, make sure the freq is correct for your radio. Mine is a VHF)
  2. Click on the read radio button. Its the one with the yellow arrow pointing away from the radio. step 1 and 2
  3. This step threw me off several times until I accidentally clicked it. Click ok to actually read the radio. enter image description here
  4. Now you can click on General settings or any other item to start working with the radio. enter image description here

I can't really help you with fixing the installation on Windows 10. As far as I know, Tytera's DFU mode is ahem nearly standards-compliant, and their drivers are unsigned. The latter might mean you have to boot windows in a special mode were signature checking for driver installation is disabled.

Anyways, there's good reasons to look into alternatives; I've only become aware of the MD-380 because of its free & open source firmwarelet / utility library that you can find at


maintained by Travis, KK4VCZ.

What it can do is automatically download the official firmware, apply some patches to it, and then, update the device (if a compatible firmware is already loaded) or just generate a firmware image that you can load through official Tytera ways on windows (which are currently failing for you) or automatically on Linux (and OS X, I presume).

Personally, I haven't used Windows in a rather longish time – I'm not a zealot, but it just feels awkward to me to use. For me, setting up a Linux installation is trivial, but that might or might not be different for you¹. Then, following the build instructions, I can build a firmware and utils rather quickly and use the md380-dfu utility to update the MD-380.

By the way, the process that KK4VCZ used to reverse-engineer this firmware and DFU utilities is rather interesting; you can read on it in PoC||GTFO 0x10, pp. 76.

¹ however, looking at the companies you work(ed) for that I can find using minimal stalking techniques, you might have dealt with more exotic environments that e.g. Fedora or Ubuntu


My suggest is to unplug program cable and remove any drivers that you installed so far. Plug program cable in to windows 10 with out the radio connected. An see if windows 10 can fine the drivers for you. also turn off any programing software for that radio. after you fine the drivers for windows 10 start program software and plug in radio. If you connect to radio always read the radio first before you try to write to it. good luck. Make sure your radio is off when you first connect to program cable.

  • $\begingroup$ Hello and welcome to ham.stackexchange.com! Please consider taking the tour to get the most from the site. 73! $\endgroup$ – rclocher3 Mar 10 '17 at 21:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.