1
$\begingroup$

End goal: Play about with RTL-SDR in GNURadio Companion

While following the instructions on this page, I've run into errors concerning the Boost C++ libraries. While building the gr-osmosdr blocks to use in GNURadio, cmake fails to complete because it cannot find Boost which is definitely installed. Version 1.57.

Last metadata expiration check performed 1:27:21 ago on Thu Jul 28 15:01:40 2016.
Package boost-1.57.0-6.fc22.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

Specifically, the error message I receive looks like...

-- Detecting C compile features - done
-- Build type not specified: defaulting to release.
-- Found Git: /usr/bin/git (found version "2.4.11") 
-- Extracting version information from git describe...
-- Configuring Boost C++ Libraries...
-- Could NOT find Boost
CMake Error at CMakeLists.txt:125 (message):
  Boost required to build gr-osmosdr

The code in CMakeLists.txt concerning Boost is...

########################################################################
# Setup boost
########################################################################
MESSAGE(STATUS "Configuring Boost C++ Libraries...")

# Although not required on my system, some users have linking issues without
SET(BOOST_REQUIRED_COMPONENTS
    thread
    system
)

if(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
    list(APPEND BOOST_LIBRARYDIR "/usr/lib64") #fedora 64-bit fix
endif(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")

set(Boost_ADDITIONAL_VERSIONS
    "1.35.0" "1.35" "1.36.0" "1.36" "1.37.0" "1.37" "1.38.0" "1.38" "1.39.0" "1.39"
    "1.40.0" "1.40" "1.41.0" "1.41" "1.42.0" "1.42" "1.43.0" "1.43" "1.44.0" "1.44"
    "1.45.0" "1.45" "1.46.0" "1.46" "1.47.0" "1.47" "1.48.0" "1.48" "1.49.0" "1.49"
    "1.50.0" "1.50" "1.51.0" "1.51" "1.52.0" "1.52" "1.53.0" "1.53" "1.54.0" "1.54"
    "1.55.0" "1.55" "1.56.0" "1.56" "1.57.0" "1.57" "1.58.0" "1.58" "1.59.0" "1.59"
    "1.60.0" "1.60" "1.61.0" "1.61" "1.62.0" "1.62" "1.63.0" "1.63" "1.64.0" "1.64"
    "1.65.0" "1.65" "1.66.0" "1.66" "1.67.0" "1.67" "1.68.0" "1.68" "1.69.0" "1.69"
)

find_package(Boost COMPONENTS ${BOOST_REQUIRED_COMPONENTS})

if(NOT Boost_FOUND)
    message(FATAL_ERROR "Boost required to build " ${CMAKE_PROJECT_NAME})
endif()

ADD_DEFINITIONS(-DBOOST_ALL_DYN_LINK)

Probably just have to point one thing to another. But I don't know which to what.

$\endgroup$
3
  • $\begingroup$ Make sure the boost development packages are installed; these typically end in -devel. $\endgroup$ Jul 28, 2016 at 14:32
  • 1
    $\begingroup$ If gr-osomosdr uses GNU autoconf, look in config.log for details. $\endgroup$
    – user
    Jul 28, 2016 at 14:46
  • $\begingroup$ Michael, no, it uses CMake and the error really is that it can't find boost this far $\endgroup$ Jul 29, 2016 at 5:18

1 Answer 1

4
$\begingroup$

Thanks to @Marcus Müller. It seemed in this instance it was the lack of the devel packages for boost. A simple...

$ sudo dnf install boost-devel

...did the trick (Well, I mean it moved me on to the next failure).

$\endgroup$
3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .