1
$\begingroup$

I am having problem charging my Baofeng UV-82HX HT. No sooner do I put up the HT on the charger, it starts showing the error lights - green stable, red flickering. I bought this off the shelf in Nov 2015, and have had good QSOs with it, but it has been having this problem since some time now.

https://www.youtube.com/watch?v=Z2gKXZyhLZU

Right now this is happening every time I charge.

Any ideas what could be going wrong, or something I can do?

$\endgroup$
5
  • $\begingroup$ How long should a 7.4V BL8 battery last if tx on 8W? $\endgroup$ Jan 11, 2016 at 6:23
  • $\begingroup$ I had to contact the shop where I bought it from, and return the charger and battery for replacement. Expecting to hear from them in another couple of weeks. $\endgroup$ Jan 18, 2016 at 5:05
  • 1
    $\begingroup$ Same here on brand new 2017 2-pack Uv5re-plus. Both seem to charge fully but charger stand blinks red green when charged.(error) So I bought a 2800-lion Baofeng original battery/upgrade and it does the same thing; however I get many hours out of the 2 radio`s using 2 chargers. The instructions say---- red no radio in cradle --- green for fully charged and red/green for error. Rather perplexing to say the least! I'm still pleased with the radios maybe this a new bios on there chip? Yet would be nice to see green and fully knowing the batteries are fully charged. $\endgroup$ Jul 25, 2017 at 22:49
  • 1
    $\begingroup$ Hello Lance, and welcome to ham.stackexchange.com! Please consider taking the tour to get the most from this site. $\endgroup$ Jul 26, 2017 at 1:27
  • $\begingroup$ I have several UV-5V+ radios and those base chargers. Whenever that happens I either try to reset the radio in the cradle or just use another. They don't fit tightly enough for good contact sometimes. $\endgroup$
    – SDsolar
    Jul 27, 2017 at 0:02

2 Answers 2

2
$\begingroup$

Try reducing the power and see if that helps. If it lets you transmit longer then the battery needs to be replaced. If it shuts off right away at low power then you may have a bad final or other malfunction in the rig itself. If you suspect the battery after this test try to borrow one and see if it does the same thing rather than buy a new one. Unless you could use a second battery. Second option is the 12V battery adapter. Always a good thing to have for long nights of radio contacts at high power. It is cheaper than a new battery.

$\endgroup$
2
  • 2
    $\begingroup$ I got a replacement battery + charger yesterday and charged it for the mandatory 5 hrs. I had good QSO with a station about 10 kms away w/o repeaters on 8W power output. Let's see how the new battery and chargers behave. Thanks for your response. $\endgroup$ Feb 9, 2016 at 10:35
  • $\begingroup$ Excellent news. The good thing about the people selling Baofeng is that they are quite aware of QC problems and are usually happy to fix user problems to preserve their reputations. For instance, I bought one that had a problem with the earphone jack so CHIRP wouldn't work with it. They sent me a new body. Glad it worked out. $\endgroup$
    – SDsolar
    Jul 27, 2017 at 0:04
1
$\begingroup$

Have you checked the voltage on the battery because I think it's full. My UV-82 charger starts blinking like that when the charge is complete. It is oscillating between charge/no charge state as soon as it sees full voltage on the battery.

$\endgroup$
2
  • $\begingroup$ It says 7.5V. But the handy doesn't operate long enough. It switches off at the first tx.. $\endgroup$ Feb 1, 2016 at 2:24
  • 1
    $\begingroup$ On the replacement battery and charger I got, after its mandatory 5 hrs charging cycle, I was seeing a 8.4V charge on the battery. $\endgroup$ Feb 9, 2016 at 10:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .