0
$\begingroup$

Recently I inherited 2x Motorola GM340 (no LCD screen version) Vhf mobile radios, The one radio works and seems to have been setup to act as a repeater and I am assuming the other was too.

enter image description here

However when I power on the 2nd radio all the lights flash for a split second and then the radio does nothing but draw 160mA. The working radio draws about 260mA when powered on.

Unfortunately the previous owner is no longer with us so I don't have any other info on the non-functional radio.

I tried reading the CodePlug but it does not work in this state.

I carefully opened up the radio and inspected both sides of the Button board and the main board but there's no sign of damage and there seems to be power throughout the device so I don't think any internal fuse or diode has blown.

I tried pulling pin 10 of the AUX connector to 12v in case it was using ignition sense and the radio still just flashes then nothing.

No audio is played either so I can't really use the manual troubleshooter since the troubleshooting relies on audio and LED flashes. The speaker works fine in the other radio... so it seems to be a problem with the main board.

I'm thinking it could be a corrupted CodePlug or firmware but I don't have a RIB and it's not easily obtainable so I'm in a bit of a pickle.

So my question is: Has anyone had a similar issue with the Motorola GM340 mobile radio?

Any suggestions and pointers will be much appreciated thanks.


BUTTONS PANEL BACK

enter image description here


PCB TOP

enter image description here


PCB BOTTOM

enter image description here

$\endgroup$
1
  • $\begingroup$ re "but I don't have a RIB and it's not easily obtainable" a cursory google search for Motorola GM340 RIB shows many relatively inexpensive options. $\endgroup$
    – webmarc
    Commented Jul 9 at 13:46

0

You must log in to answer this question.