I am trying to QSO on 17m, 20m, 40m, and 160m with an IC-756PRO.

I’m using WSJT-X in FT8 mode via a CI-V for CAT control and SignaLink for audio. System sound settings appear correct. Control tests of PTT and CAT succeed (in the Radio tab of WSJT-X).

My 40m and 160m antennas can receive pretty well (30-40db RX on average). I don’t have an external amp yet, although the 756PRO has 2 internal amp settings. RX and TX are turned up on SignaLink. I have been calling CQ and trying to answer other nearby radios’ calls for a week but it seems no one is receiving my TX.

SignaLink’s and the radio’s TX lights come on and I see the record of the TX in WSJT-X. However, in addition to the lack of response from all other radios, I also don’t show up on the Reverse Beacon Network or similar sites.

What should I do to troubleshoot the problem?

I’ve just noticed that if I transmit a tone with the WSJT-X “Tune” button on 6m that I can pick it up on a SDR I have running on another computer. So there is at least some tiny ability to TX.enter image description here

  • $\begingroup$ What about the output power meter ("Po" scale with the relevant METER setting) on the 756? $\endgroup$ Nov 12, 2022 at 19:05
  • $\begingroup$ @KC2G Excellent question. OK so right now while I am just RX it is about 55 and when I TX it goes down to 0… $\endgroup$
    – Hack-R
    Nov 12, 2022 at 19:44
  • $\begingroup$ Added a pic of a cheap external SWR and Power meter. Doesn’t appear to be picking anything up. Same happened with an old Lafayette field strength meter. $\endgroup$
    – Hack-R
    Nov 12, 2022 at 22:35
  • 1
    $\begingroup$ Are the jumpers in the SignalLink set correctly? Could be the audio it's sending out isn't making it to the transmitter $\endgroup$
    – Duston
    Nov 22, 2022 at 14:22
  • $\begingroup$ @Duston Thanks for the question. After another 10 - 15 hours of troubleshooting it works now :) It works with Rigblaster, anyway. I guess I will add a self-answer, but I'm only 80% sure I know what fixed it. $\endgroup$
    – Hack-R
    Nov 26, 2022 at 2:23

1 Answer 1


At long last, I got the radio to transmit just fine. At this point I'm using RigBlaster, although that's less because it was the solution and more because it's something I was trying along the way while troubleshooting.

I believe what led to it working was some combination of:

  • better antenna tuning
  • making sure the CI-V address on the radio was 5C not 5D

The CI-V address certainly was not the entire problem. It got changed by West Mountain's tech support while troubleshooting, but changing it back was the final action I took that directly led to the first successful TX and QSO.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .