0
$\begingroup$

I have an Ettus B210, which has 4 ports: RF Input A: RX/TX and RX2, and RF Input B: RX2 and RX/TX. In GNU Radio using the USRP block I can use both ports of RF Input A. But I don't succeed to use the inputs of RF Input B.

What I tried: on the General tabsheet I have a setting 'Num Channels', which is default set to 1. When I switch to 'RF Options' tabsheet, there is a setting 'Ch 0: Antenna' , which I can set to RX/TX, RX2 and RX1. When I use RX/TX or RX1, the LED of the corresponding input on the RF Input A panel lits up green, and it works (I can see data), so that's okay (besides that the RX2 on the Ettus panel is RX1 in GNU Radio, but that was easy to find out). But the third option, RX2, does not work, I got the error 'Port is not connected'.

When I change on the general tabsheet the setting 'Num Channels' to 2, then on the 'RF Options' page I see also 'Ch 1: Antenna', which I also can set to RX/TX, RX2 and RX1. However, whatever I select, I got the error 'Port is not connected'.

I checked this forum, Google, Ettus B200/B210 datasheet, but I cannot find info to get the RF Input B going. What is it what I'm doing wrong?

So, my questions:

  • Why has Ch 0: Antenna 3 selections, why there are only 2 working (or is there an Ettus model which has 3 ports in its RF Input panel)?
  • What is the proper configuration of the USRP block to use the 'RF Input B' inputs?
$\endgroup$

1 Answer 1

1
$\begingroup$

"Port is not connected" is usually a GNU Radio flow graph level problem, rather than a hardware or driver issue; it's telling you that one of the ports on a block is not correctly wired.

Could you post a picture of your flow graph from GRC? I guess that maybe your change to the USRP source has caused the block to grown an additional port that you didn't notice.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .