GNU Radio v3.8 with Qt-GUI on Ubuntu 20.04

Before starting on something new I always test my setup with this GNURadio hello world flow graph which I know for sure, that it used to work.

The other day, on Ubuntu when I fired up the above flow graph with GNU Radio, there were missing blocks everywhere. Apparently the GNU Radio version that comes with Ubuntu 20.04 is version 3.8, where the WX GUI has been deprecated.

I replaced the WX GUI Sliderwith Qt GUI Range and the WX GUI Sinks with the Qt GUI sinks and so on. The important blocks such as WBFM Receive, Audio Sink, Rational Resampler, RTL-SDR Source are still the same and remain untouched. All their sample-rates, etc are as before.

Overflows or underruns

The flow graph runs, except it kept giving me aU (or O) symbols in the console with very funny audio.

I duckduckgo-ed and found out that the problem could be with the sample rate that I am feeding to the audio sink. Strange, as I have not touched that and it used to work fine.

Anyways, for fun's sake, I checked all the audio sample rates for the audio sink from 16kHz to 48kHz one after the other but nothing helped. For the lower rates I kept getting overruns and for the higher rates, I kept getting underflows.

The Numbers

I then rechecked the numbers, and the WBFM Receive block outputs a quadrature rate of 250k. The Rational Resampler decmiates by 250 and interpolates by 24. So 24kHz does seem to be the right sample rate for the audio sink. So the numbers add up. Don't know where's the problem.

Just for fun I changed the interpolation rate to be above the Sample Rate of the Audio Sink. For the 24kHz sample rate on the Audio Sinkan interpolation rate of 40 would, e.g. give at the beginning underflow errors but then after a few seconds it would start giving overruns. The lower I brought the interpolation rate, the quicker the flowgraph went from underflows to overruns. BUT there was no interpolation rate for which I could get a stable error free output.

Can my hardware handle it? YES!

From one of the other forums, I saw that someone mentioned that maybe the hardware just cannot handle that (or any of the given) sample rate(s).

I tested with dial_tone.py on my PC and got no errors. All worked fine, just like it had with GNU Radio v3.7.

Compare with GNU Radio on Windows 10

So as a quick test, I rebooted the PC and fired up Windows 10 where I had GNU Radio v3.7.13.5 installed. Unforunately, I had forgotten about this problem with GNU Radio v3.7.13.5.

So I downgraded to an older version from here, where I remember the original FM flow graph worked long time ago.

Unfortunately, that version of GNU Radio v3.7.11 on Windows does NOT open the Qt flow graph for FM Receiver but IF I run the WX GUI based FM Receiver it worked fine. (a bug in v3.7.11?)


So apparently GNU Radio v3.8 on Ubuntu has a bug with the audio sink sample rate?



You must log in to answer this question.

Browse other questions tagged .