I just bought my first WRT54G (V3), and wanted to build a mesh network (Using the Broadband-ham firmware, http://www.broadband-hamnet.org/ , which as I understand is based on OpenWrt). I wasn't paying careful enough attention, and downloaded the firmware for the WRT54G v1, and burned it. I'm unable to get to any online documentation, and have been working my way though troubleshooting this. Here's what I can figure out.

  1. I can get the router into safe mode. I can't figure anything from there that's useful I can do, but I've done it.
  2. The router accepts pings on, giving a TTL code 100 if I start from the beginning, and 64 if in safe mode.
  3. I have this hooked up to a Windows 7 machine. I've tried using the TFTP software, but while it occasionally looks like it's trying to erase the firmware. It stays there for a few seconds, then it looks like it times out, and tries again.
  4. I've tried rebooting this while running a large loop on tftp.
  5. I've tried TFTP also when running in safe mode.
  6. I found that the error being reported is "Code pattern is incorrect". Any idea what that means?

Any ideas about what else to try? I feel like I've almost got it figured out, but that last 10% is killing me... Thanks!


2 Answers 2


After a long time pondering about this, I realized the trick. The first problem is that I had a version 3v of the router, and I installed the 3g version of the software. That doesn't work at all. I should have used the file bbhn-1.1.2-wrt54g-2.4-squashfs.bin instead of bbhn-1.1.2-wrt54g3g-2.4-squashfs.bin (For the latest, probably something different for the older version). As for fixing the problem, the solution involved was the following

  1. Set up a fixed IP address on a computer.
  2. Run "ping -t", which will continually ping the router.
  3. Reboot the router, holding the reset button.
  4. If you see a message with "TTL=100", you've hit the mark! Otherwise, keep trying.
  5. Run the tftp program, available in a few places on the Internet.

All in all, this recovery process worked, and I'm (Only 6 months late...) able to get the mesh network up. Now, to figure out some applications for it...


Ah, the mesh is taking the area by storm. We had a demo at our club last month and folks are working on getting a few of these and starting up some nodes. Flashing the router is probably the trickiest part. Fortunately, the Linksys routers have a long history of being reprogrammed and therefore there is a lot of info on this topic. I would suggest starting with the excellent wiki at DD-WRT.com that has a long article on unbricking.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .