0
$\begingroup$

I am trying to use Gnuradio to build QPSK transmission with satellites simulation for educational purposes. Unfortunately, I am unable to add new blocks after "find blocks" (blue magnifier icon) button of Gnuradio stopped functioning. It was working fine till yesterday, but somehow it suddenly stopped responding to my clicks. But I can execute flowgraphs. Just can`t use find blocks buton. I have tried to uninstall and install with following commands: 1) sudo apt-get purge --auto-remove gnuradio
2) sudo apt-get install gnuradio

But problem still persists. By the way, after reinstalling, when I open the gnuradio, it still opens last opened flowgraph. Why would it remember last flowgraph if I uninstalled config/data files(...purge --auto-remove...)? Anyways, I am providing overall screenshot, maybe there is something wrong that I am missing. I need to fix this and continue workign asap, so any help is hugely appreciated! Current screenshot of the Gnuradio

$\endgroup$
  • $\begingroup$ Welcome to ham.stackexchange.com! $\endgroup$ – rclocher3 Nov 27 '19 at 21:55
  • $\begingroup$ Thanks rclocher3! :) $\endgroup$ – Galib Nov 28 '19 at 9:58
1
$\begingroup$

It looks like the right sidebar, where the list of blocks is, is collapsed. Try dragging from where the faint dots in the middle of the right edge of the window are.

| improve this answer | |
$\endgroup$
  • $\begingroup$ exactly that. This, for some reason, started happening randomly to GNU Radio 3.7 installations. It's the third time I see it, and I have no clue whatsoever where it comes from. $\endgroup$ – Marcus Müller Nov 28 '19 at 6:48
  • $\begingroup$ Thanks Kevin, it worked!!! $\endgroup$ – Galib Nov 28 '19 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.