2
$\begingroup$

I bought a pre-owned Yaesu FT-8900R. Sadly turned out that the radio doesn't turn on. When I hold the power button (the right bottom one) the speaker pops briefly but nothing else happening. The previous owner claims very persistently that it worked before shipping.

Assuming that the device was not damaged during the shipping I would like to exclude any "stupid" reasons of malfunction before bringing it to the repair service. I'm hoping that there are some FT-8900R owners here who might observe the described behaviour before.

I already checked the fuses, re-soldered all connections on the power cable, opened the top door of the case to make sure there are no dust or any visible damage on the board. The multimeter shows that the board gets stable 13.8V from the SamplexPower SEC-1235M power supply.

What else should I check?

$\endgroup$
  • $\begingroup$ > Presumably working FT-8900R doesn't turn on. What can be a reason? — It is no longer a working FT-8900R. $\endgroup$ – Lance Jul 9 '19 at 13:18
4
$\begingroup$

OK, I figured it out. Turned out a little FFC cable disconnected inside the panel during the shipping. After fixing this the radio worked flawlessly!

$\endgroup$
  • 1
    $\begingroup$ To improve this answer can you show a photo or explain what and where the FFC Cable is? Thank you! $\endgroup$ – whiskeychief Jul 19 '19 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.