1
$\begingroup$

Thanks. Solved. Baofeng 888s, programmed with chirp, worked great. I hit the device with CHIRP many times, Everything was ok., but moni button after a month, didn't work. First I thought that the problem is for programming. I tried to change side key options by programming, but no effect. When push it, no reflection. Is the side key burnt? The device is new and I confused about this problem. I looked at the keys by magnifier but nothing was seen. I checked their connections by multi meter and I found the problem is in the key connection plates, not in other parts. I opened carefully stick ribbon over the "moni" key and saw a very small dust between two plates of the key, and remove it and the key acts very good and is ok.

$\endgroup$
  • $\begingroup$ Hello, and welcome to hamSE. Thank you for your insight, but I closed this because it was not a question. We invite you to edit it into the form of a question, and then post a separate answer so that it can be re-opened. $\endgroup$ – Mike Waters Jun 27 '19 at 16:30

Browse other questions tagged or ask your own question.