1
$\begingroup$

I've been playing around with RTL-SDR and Unitrunker attempting to get a police scanner working. I followed the tutorial here: https://sites.google.com/site/policescannerhowto/

Everything works as expected until I run Unitrunker and try to add the two receivers. When I do so I only see the top section as seen in this image:

Unitrunker display

This happens when I add the control receiver as well. In the tutorial and all the other examples I've seen all over the net, there are many more fields underneath those which are necessary to get things working. I know the RTL-SDR receiver is working, I am able to tune to various radio stations with SDR#.

What could be causing this? And what steps can I take to fix it?

$\endgroup$
2
$\begingroup$

The phrase "Everything works as expected" covers a lot of ground, so I'm going to assume that included:

  • Installing the Zadig drivers when you first plugged your RTL-SDR device(s) into your USB port rather than relying on the Plug-and-Play drivers that would've been installed automatically.

  • Running your RTL-SDR device(s) under a basic recever program such as HDSDR or SDRSharp and confirming that you can receive a simple FM signal such as NOAA weather broadcasts in the 162 MHz range.

  • Allowing your RTLSDR device(s) to warm up and stabilize by letting your basic receiver program such as HDSDR or SDRSharp run for a half hour or more and then calibrating your RTLSDR device's "Frequency Correction" parameter (ExtIO button on HDSDR or the gear icon on SDRSharp) to the dial frequency of the HDSDR/SDRSharp software.

  • Making note of the "Frequency Correction" parameter and writing it on a piece of tape that you affixed to your RTLSDR device(s).

If that has all been completed successfully then you click on the "Type | Signal" line in the screen shot you posted, then in the drop down menu select RTL2832U or the equivalent RTL device listing, enter your "Frequency Correction" parameter into Unitrunker's "Correction" line, selecting the "Drift Correct" option and pressing the PLAY button (right-pointing triangle).

$\endgroup$
  • $\begingroup$ So it turns out I just needed to press play to make the fields appear. Thanks for the correction tips as well though. $\endgroup$ – shenk May 10 '19 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.