0
$\begingroup$

This question is very similar Yaesu G-5400B rotator controller problem, with a bit of a twist.

I'm getting a consistent 5.84 VDC up to the rotators and the expected 0-5.84 VDC at terminals A1-3 and E1-3, and thence to VR2 and VR4. But tracing those voltages through the circuits to the eventual outputs at DIN pins 1 and 6 (to my computer interface - a K3NG device) I'm only seeing a maximum of 1.5 to 2 VDC if I rotate VR2 and VR4 to minimum. (The meters are reading just fine, and are stable.) Thoughts on this? Perhaps the OpAmps Q3 and Q4 have failed? They're obviously still passing voltage, just not 0-5.84 volts. I'm hoping it's something simpler.

$\endgroup$
  • $\begingroup$ What are the maximum voltages at DIN 1 and 6 if you disconnect the K3NG device? $\endgroup$ – Glenn W9IQ Jan 15 at 1:12
  • $\begingroup$ It also helps to know if this ever worked correctly in the past or if this your first attempt at getting the two controllers interfaced. $\endgroup$ – Glenn W9IQ Jan 15 at 1:40
  • $\begingroup$ Second question first: Yes, this worked great about 8 years ago when I disassembled the system. I was using the old FODTrack parallel-port-driven-DOS-based controller/software. At the time, I never checked the output voltages, since the system worked! $\endgroup$ – Brad - N7IVV Jan 15 at 2:53
  • $\begingroup$ First question: At this point I'm doing all of my measurements WITHOUT the controller attached. $\endgroup$ – Brad - N7IVV Jan 15 at 2:54
  • $\begingroup$ With nothing connected to the output DIN, I'm getting the following voltages (I'll just use the El side): $\endgroup$ – Brad - N7IVV Jan 15 at 6:31
1
$\begingroup$

It is unlikely that both op amps have failed, especially since the other half of each op amp drives the meters, which you stated are still working properly.

I am initially concerned that you are seeing 5.84 VDC at the rotor. The input to the range pots that are in the rotor should be ~8 volts. This may indicate that you have a wiring error or a high resistance wiring connection somewhere. Check the voltage at the rotor control box A1 and E1 with and without the rotor connected. It should stay at ~8 volts in both cases.

If E1 an A1 are not at 8 volts with the rotor disconnected, this would indicate a problem with the 8 volt regulator circuit, including Q2. Given the age of the rotor, it could be that C1 is no longer up to spec. Check this with volt meter across the capacitor. It should read near 0 AC volts and near 12 DC volts.

To adjust the output voltage on the DIN connector, you must adjust VR3 and VR4 (you stated VR2 and VR4).

Remove the K3NG device from the DIN plug. Check that the op amp inputs (Q3 pin 3 and Q4 pin 3) follow the voltage output of VR3 and VR4 respectively. If they do not, then check the clamping diodes D12, D13, D24 and D25 for correct functioning.

If you find nothing amiss in the prior step, check the op amp outputs (Q3 pin 1 and Q4 pin 1) to see that they follow VR3 and VR4 respectively. If not, check the output clamping diodes D10, D11, D22 and D23 for correct functioning.

If you find nothing amiss in the prior step, then suspect a problem in the K3NG controller or the interconnect cable wiring. A common problem is incorrect pin numbering for the interface cable:

enter image description here

Based on the comments, here is a brief circuit description of the relative part of the circuit:

Q2 is a voltage regulator that feeds 8 volts to the position sensing pots in the rotor. The resulting voltage back to the controller ranges from 0 to ~7.8 volts. The maximum voltage will be less due to the resistance of the wiring between the controller and the rotor.

The output voltage from the rotor pots is fed into VR3 and VR4, each of which is in series with a 4.7k ohm resistor. The output voltage of VR3 and VR4 is conditioned, divided in half, and fed into an op amp circuit with a gain of ~2. The output of the amp amp is further conditioned and current limited by a 220 ohm resistor before being fed to the DIN jack on the back of the rotor controller.

VR3 and VR4 set the maximum output voltage present on DIN pins 1 and 6 when the rotor is in its maximum position. They should be adjusted when the rotor is at its maximum position in both axes (both meters full right). The output adjustments (negating the wire resistance mentioned earlier) should range from ~2.5 volts to ~7.8 volts.

Here is the schematic for the az-el rotor:

enter image description here

$\endgroup$
  • $\begingroup$ I tend to agree with you about both OpAmps failing, especially since they are actually TWO separate units. As you are aware, the other half of the OpAmps are being used for the meters - which work fine. Yes, you are correct. VR3 and VR4. I just entered the wrong numbers. $\endgroup$ – Brad - N7IVV Jan 15 at 2:58
  • $\begingroup$ (I was actually just removing the screws from the case to start taking measurements again when I checked this thread!) I've been reading voltages at test points 12 and 15 for voltages from the rotator (E1-3 and A1-3), and points 13 and 16 for the voltages out to the control output jack. Just FYI, I'm reading the schematic for the G-5500 most of time, because it is a nice clear copy! I have the schematic for the G-5400/G-5600 also, but it isn't a very clear copy. The schematics are identical for all three units for the circuits we're working with. $\endgroup$ – Brad - N7IVV Jan 15 at 3:04
  • $\begingroup$ The voltage going into VR3 and VR4 match that coming in on terms E2/A2, of course, But at points 12 and 15 I'm only getting the 0-1.5 or 2.0 volts. And that is also what I'm measuring at points 13 and 16. And proportionately those voltages seem to be tracking with the voltage changes at E2/A2. From my rudimentary research lately, I believe the OpAmps are supposed to be boosting the input voltages up on the outputs? $\endgroup$ – Brad - N7IVV Jan 15 at 3:10
  • 1
    $\begingroup$ I added additional diagnostics and a circuit description to my answer. $\endgroup$ – Glenn W9IQ Jan 15 at 16:14
  • 1
    $\begingroup$ @Brad-N7IVV I forgot to tag you for the last two comments. $\endgroup$ – Glenn W9IQ Jan 15 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.