3
$\begingroup$

I paired my old Kenwood TS-50 with serial, by using FTDI TTL-232-5V-AJ USB to serial converter. I used ideas from here: http://steeman.be:8080/posts/TS-50%20USB%20Interface/ and here http://i.imgur.com/BmYMq2v.jpg

I have Linux Ubuntu 18.04 and I can detect my serial to usb converter, by using dmesg:

[ 1596.365806] ftdi_sio 1-5:1.0: FTDI USB Serial Device converter detected
[ 1596.365857] usb 1-5: Detected FT232RL
[ 1596.371078] usb 1-5: FTDI USB Serial Device converter now attached to ttyUSB0

To be sure that I can connect to serial port I first wanted to be sure by checking that connection works with minicom, but it gives me:

minicom: cannot open /dev/ttyUSB0: Permission denied

Despite I am in dial out group and I did all that is written here: https://websistent.com/fix-serial-port-permission-denied-errors-linux/

I can temporary solve that by using it with sudo. That I did, but minicom says, that ir is offline.

I also tried rigctl:

ffu@ffu-desktop:~$ rigctl -m 201 -r /dev/ttyUSB0 -s 4800 -v
rig_open: error = IO error 
ffu@ffu-desktop:~$ sudo rigctl -m 201 -r /dev/ttyUSB0 -s 4800 -v
Opened rig model 201, 'TS-50S'

Rig command: f
rigctl_parse: input_line: f
get_freq: error = Invalid parameter

Its looks like from me that apparently something is wrong at OS level, but what?

$\endgroup$
  • $\begingroup$ Probably I missed restart - now the "Permission denied" problem is gone. But I still getting the "Invalid parameter" error with rigctl. :( Now I am thinking about serial port parameters - are they right... $\endgroup$ – Jony Forester Oct 28 '18 at 21:18
  • 1
    $\begingroup$ sourceforge.net/p/hamlib/mailman/message/34302264 There was a bug causing a similar error some time ago, I assume you have the latest version of rigctl? Can you try (or borrow) a different rig to see if you get the same results? $\endgroup$ – Duston Oct 30 '18 at 14:10
  • $\begingroup$ +1 for doing a good job of summarizing your problem and what you've done to correct it so far. $\endgroup$ – rclocher3 Nov 1 '18 at 23:49
  • $\begingroup$ I have latest major version: rigctl, Hamlib 3.1. Does the latest minor version 3.3 will change something? I could try different rig but it will not be soon. $\endgroup$ – Jony Forester Nov 5 '18 at 11:25
  • $\begingroup$ Tried to setup some serial sniffer: jpnevulator --ascii --tty "/dev/ttyUSB0" --read But yet no luck - no output at all. :( $\endgroup$ – Jony Forester Nov 5 '18 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.