Can someone please give me a clue here? I'm having problems receiving data from the IC 9100 radio.

I want to receive ax25 packets using FSK G3RUH modulation with an IC-9100 radio. It is configured to work on D-USB mode (on the settings menu the radio data mode is on USB). The radio is connected to PC using an A to B USB cable. As for the modem, I'm using a Soundmodem of George Smart M1GEO under Debian 9 Stretch. The radio is also connected to an SSB7000 preamplifier and crossed yagi antenna.

When sending periodic AX25 beacon from a secondary transceiver, I can see received signal on the ICOM LCD but I can't see any traffic on the Ax25 port.

To clear any doubts about the cp210x drivers (whether they re configured or not the right way) I consulted silicon labs site and they confirm that all new linux system have pre-built cp210x module. the only difference that exists between the latter and the one they have in their site is the GPIO driver support. Also from what i have seen in forums one can use the driver already supported and don t have to install new ones. To confirm that my system really support them, I used the following commands (alongs with screanshots of the output i got):

  1. lsusub lsusb command

  2. cat /proc/asound/cards asound cards

  3. dmesg | grep cp210x enter image description here

Finally, here are the specs of the ttyUSB0 (same for ttyUSB4): enter image description here ..ctd... enter image description here

I think that the installed cp210x driver works just fine... unless there is somthing else i m not aware of... PLease would you help me on this.. I m just lost. Thank you so much for taking the time to read my post. Best

  • It's not a very long post at all! So, am I getting this right (please say yes or no): a) You receive audio from the IC-9100 via USB; b) this is realized using a sound card device, which the IC-9100 USB driver offers c) you use that sound card in the soundmodem software. d) you observe the AX.25 packet output of that software e) the software doesn't output any packets on said output. – Marcus Müller Jul 16 at 12:20
  • Thank you for the quick reply!! Yes exactelly. And when I checked, the soundmodem software doesn t receive the audio signals from the USB port. I deactivated the system soundcard to ensure that audio is routed directly from icom integrated soundcard to software, but still didn t work :( I also checked PC volume setting using pavucontrol but to no avail.. what do you think?? – Ibtissam Latachi Jul 16 at 13:22
  • @IbtissamLatachi when you look at pavucontrol and the radio is receiving, does the level meter under the radio device move around? Also, while in pavucontrol recording tab, have you confirmed that soundmodem is actually listening to that device and not another? – hobbs - N2EON Jul 23 at 0:13
  • Yes the level meter of the icom radio moves around upon reception of the signal, and to ensure that soundmodem is actually listening to radio sound card, I blacklisted all of the other existing devices on my laptop and made sure that soundmodem is using that right device by precising the card index. didn t work inspite of all of this :( Thanks for your reply by the way ;) – Ibtissam Latachi Jul 23 at 12:39

You need to install the Icom USB drivers on your PC. You mentioned that your PC is running Linux but I am not aware of any Linux drivers from Icom - I only see Windows support on their website.

Once you have successfully installed the Icom drivers and connected the radio via the USB cable, you will see two new USB devices. You must select the USB2 option for receiving data. The Icom radio must also be configured to route the data to USB2 using menu option 63.

  • The silicon labs cp210x usb drivers are native in linux systems, hence there is no need for any driver installation. When plugging the usb I could find my two usb ports along with the soundcard codec. I checked the volume settings and made sure that my system is using USB audio CODEC input and ouput, but to no avail. I have doubts that maybe the PC USB port doesn t provide enough current to handle audio traffic which might cause port blackouts... What do you think? – Ibtissam Latachi Jul 18 at 12:16
  • @IbtissamLatachi It doesn't seem likely that it is a port current issue. The Icom USB port is probably powered from the Icom side. If you have a USB breakout box, you could take some measurements to confirm this. I still suspect that it is a driver issue. – Glenn W9IQ Jul 20 at 10:22
  • 2
    Glenn, there is seldom a need to install drivers in Linux. Most drivers are built into the kernel. – Mike Waters Jul 24 at 14:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.